Biopython dropping Python 2.4 Support?

This is a reminder that the forthcoming Biopython 1.56 release is planned to be our last release to support Python 2.4.

Looking back, we supported Python 2.3 for about six years – it was released July 2003, and Biopython 1.50 released in April 2009 was the last to support it. Similarly, Python 2.4 was released six years ago (November 2004).

Dropping Python 2.4 support will allow use to assume standard library modules like the ElementTree XML parser and SQLite 3 support will be available. There are also several new language features in Python 2.5+ which will be useful, and it should make supporting Python 3 a little easier as well.

Most operating systems which come with Python now ship with Python 2.5 or later, with the notable exception of CentOS where Python 2.4 is still used. Also, those of you running a Linux server may still be running an old but still supported OS – for example the Ubuntu 6.06 LTS (Dapper Drake) server edition is maintained until June 2011, and comes with Python 2.4.

If you would be negatively affected by Biopython dropping support for Python 2.4, please let us know as soon as possible, ideally via the mailing list.

Thank you.

This entry was posted in Biopython, Blogroll, Code, Community, Development, OBF Projects and tagged , . Bookmark the permalink.